Как уменьшить разрядность числа в excel

Как уменьшить разрядность числа в excel

Округление чисел в Microsoft Excel

Округление чисел в Excel

При выполнении деления или работе с дробными числами, Excel производит округление. Это связано, прежде всего, с тем, что абсолютно точные дробные числа редко когда бывают нужны, но оперировать громоздким выражением с несколькими знаками после запятой не очень удобно. Кроме того, существуют числа, которые в принципе точно не округляются. В то же время, недостаточно точное округление может привести к грубым ошибкам в ситуациях, где требуется именно точность. К счастью, в программе имеется возможность пользователям самостоятельно устанавливать, как будут округляться числа.

Особенности округления чисел Excel

Все числа, с которыми работает Microsoft Excel, делятся на точные и приближенные. В памяти хранятся числа до 15 разряда, а отображаются до того разряда, который укажет сам пользователь. Все расчеты выполняются согласно хранимых в памяти, а не отображаемых на мониторе данных.

С помощью операции округления Эксель отбрасывает некоторое количество знаков после запятой. В нем применяется общепринятый способ округления, когда число меньше 5 округляется в меньшую сторону, а больше или равно 5 – в большую сторону.

Округление с помощью кнопок на ленте

Самый простой способ изменить округление — это выделить ячейку или группу ячеек и, находясь на вкладке «Главная», нажать на ленте на кнопку «Увеличить разрядность» или «Уменьшить разрядность». Обе кнопки располагаются в блоке инструментов «Число». Будет округляться только отображаемое число, но для вычислений при необходимости будут задействованы до 15 разрядов чисел.

При нажатии на кнопку «Увеличить разрядность» количество внесенных знаков после запятой увеличивается на один.

Увеличить разрядность в Microsoft Excel

Кнопка «Уменьшить разрядность», соответственно, уменьшает на одну количество цифр после запятой.

Уменьшить разрядность в Microsoft Excel

Округление через формат ячеек

Есть возможность также выставить округление с помощью настроек формата ячеек. Для этого нужно выделить диапазон ячеек на листе, кликнуть правой кнопкой мыши и в появившемся меню выбрать пункт «Формат ячеек».

Переход в формат ячеек в Microsoft Excel

В открывшемся окне настроек формата ячеек следует перейти на вкладку «Число». Если формат данных указан не числовой, необходимо выставить именно его, иначе вы не сможете регулировать округление. В центральной части окна около надписи «Число десятичных знаков» просто укажите цифрой то количество знаков, которое желаете видеть при округлении. После этого примените изменения.

Формат ячеек в Microsoft Excel

Установка точности расчетов

Если в предыдущих случаях устанавливаемые параметры влияли только на внешнее отображения данных, а при расчетах использовались более точные показатели (до 15 знака), то сейчас мы расскажем, как изменить саму точность расчетов.

Переход в параметры в Microsoft Excel

    Перейдите на вкладку «Файл», оттуда — в раздел «Параметры».

Lumpics.ru

Применение функций

Если же вы хотите изменить величину округления при расчете относительно одной или нескольких ячеек, но не хотите понижать точность расчетов в целом для документа, в этом случае лучше всего воспользоваться возможностями, которые предоставляет функция «ОКРУГЛ» и различные ее вариации, а также некоторые другие функции.

Среди основных функций, которые регулируют округление, следует выделить такие:

  • «ОКРУГЛ» – округляет до указанного числа десятичных знаков согласно общепринятым правилам округления;
  • «ОКРУГЛВВЕРХ» – округляет до ближайшего числа вверх по модулю;
  • «ОКРУГЛВНИЗ» – округляет до ближайшего числа вниз по модулю;
  • «ОКРУГЛТ» – округляет число с заданной точностью;
  • «ОКРВВЕРХ» – округляет число с заданной точностью вверх по модулю;
  • «ОКРВНИЗ» – округляет число вниз по модулю с заданной точностью;
  • «ОТБР» – округляет данные до целого числа;
  • «ЧЕТН» – округляет данные до ближайшего четного числа;
  • «НЕЧЕТН» – округляет данные до ближайшего нечетного числа.

Для функций «ОКРУГЛ», «ОКРУГЛВВЕРХ» и «ОКРУГЛВНИЗ» используется следующий формат ввода: Наименование функции (число;число_разрядов) . То есть если вы, к примеру, хотите округлить число 2,56896 до трех разрядов, то применяете функцию «ОКРУГЛ(2,56896;3)». В итоге получается число 2,569.

Округление числа в Microsoft Excel

Для функций «ОКРУГЛТ», «ОКРВВЕРХ» и «ОКРВНИЗ» применяется такая формула округления: Наименование функции(число;точность) . Так, чтобы округлить цифру 11 до ближайшего числа, кратного 2, вводим функцию «ОКРУГЛТ(11;2)». На выходе получается результат 12.

Округление до ближайшего кратного числа в Microsoft Excel

Функции «ОТБР», «ЧЕТН» и «НЕЧЕТ» используют следующий формат: Наименование функции(число) . Для того чтобы округлить цифру 17 до ближайшего четного, применяем функцию «ЧЕТН(17)». Получаем результат 18.

округление до четного числа в Microsoft Excel

Функцию можно вводить, как в ячейку, так и в строку функций, предварительно выделив ту ячейку, в которой она будет находиться. Перед каждой функцией следует ставить знак «=».

Существует и несколько другой способ введения функций округления. Его особенно удобно использовать, когда есть таблица со значениями, которые нужно преобразовать в округленные числа в отдельном столбике.

  1. Переходим во вкладку «Формулы» и кликаем по кнопке «Математические». В открывшемся списке выбираем подходящую функцию, например, «ОКРУГЛ». Округление через формулу в Microsoft Excel
  2. После этого открывается окно аргументов функции. В поле «Число» можно ввести число вручную, но если мы хотим автоматически округлить данные всей таблицы, тогда кликаем по кнопке справа от окна введения данных. Переход к выбору числа в Microsoft Excel
  3. Окно аргументов функции сворачивается. Теперь щелкнуте по самой верхней ячейке столбца, данные которого мы собираемся округлить. После того, как значение занесено в окно, жмем по кнопке справа от этого значения. Возвращение к аргументам функции в Microsoft Excel
  4. Опять открывается окно аргументов функции. В поле «Число разрядов» записываем разрядность, до которой нам нужно сокращать дроби и применяем изменения. Переход к изменению разрядности в Microsoft Excel
  5. Число округлилось. Чтобы таким же образом округлить и все другие данные нужного столбца, наводим курсор на нижний правый угол ячейки с округленным значением, жмем на левую кнопку мыши, и протягиваем ее вниз до конца таблицы. Копирование формулы в Microsoft Excel
  6. Теперь все значения в столбце будут округлены. Значения в таблице округлены в Microsoft Excel

Как видим, существуют два основных способа округлить видимое отображение числа: с помощью кнопки на ленте и путем изменения параметров формата ячеек. Кроме того, можно изменить и округление реально рассчитываемых данных. Это также можно сделать по-разному: изменением настроек книги в целом или применением специальных функций. Выбор конкретного метода зависит от того, собираетесь ли вы применять подобный вид округления для всех данных в файле или только для определенного диапазона ячеек.

Как уменьшить разрядность числа в excel

Если отображение ненужных разрядов вызывает появление знаков ######, или если микроскопическая точность не нужна, измените формат ячеек таким образом, чтобы отображались только необходимые десятичные разряды.

Округка числа до ближайшей основной единицы

Если вы хотите округить число до ближайшего крупного блока, например тысяч, сотен, десятков или единиц, используйте функцию в формуле, выполните следующие действия:

С помощью кнопки

Выделите ячейки, которые нужно отформатировать.

На вкладке Главная выберите команду Увеличить разрядность или Уменьшить разрядность, чтобы отобразить больше или меньше цифр после запятой.

С помощью встроенного числового формата

На вкладке Главная в группе Число щелкните стрелку рядом со списком числовых форматов и выберите пункт Другие числовые форматы.

В списке Категория выберите значение Денежный, Финансовый, Процентный или Экспоненциальный в зависимости от типа ваших данных.

В поле Число десятичных знаков введите число знаков после запятой, которые вы хотите отображать.

С помощью функции в формуле

Округлите число до необходимого количества цифр с помощью функции ОКРУГЛ. Эта функция имеет только два аргумента (аргументы — это части данных, необходимые для выполнения формулы).

Первый аргумент — это число, которое необходимо округлить. Он может быть ссылкой на ячейку или числом.

Второй аргумент — это количество цифр, до которого необходимо округлить число.

Предположим, что ячейка A1 содержит число 823,7825. Вот как можно округлить его.

Чтобы округлить до ближайшей тысяч и

Введите =ОКРУГЛ(A1;-3), что равно 1000

Число 823,7825 ближе к 1000, чем к 0 (0 кратно 1000 )

В этом случае используется отрицательное число, поскольку округление должно состоятся влево от запятой. Такое же число применяется в следующих двух формулах, которые округляют до сотен и десятков.

Чтобы округлить до ближайших сотен

Введите =ОКРУГЛ(A1;-2), что равно 800

Число 800 ближе к 823,7825, чем к 900. Наверное, теперь вам все понятно.

Чтобы округлить до ближайших десятков

Введите =ОКРУГЛ(A1;-1), что равно 820

Чтобы округлить до ближайших единиц

Введите =ОКРУГЛ(A1;0), что равно 824

Используйте ноль для округления числа до ближайшей единицы.

Чтобы округлить до ближайших десятых

Введите =ОКРУГЛ(A1;1), что равно 823,8

В этом случает для округления числа до необходимого количества разрядов используйте положительное число. То же самое касается двух следующих формул, которые округляют до сотых и тысячных.

Чтобы округлить до ближайших сотых

Введите =ОКРУГЛ(A1;2), что равно 823,78

Чтобы округлить до ближайших тысячных

Введите =ОКРУГЛ(A1;3), что равно 823,783

Округлите число в большую сторону с помощью функции ОКРУГЛВВЕРХ. Она работает точно так же, как функция ОКРУГЛ, за исключением того, что она всегда округляет число в большую сторону. Например, если необходимо округлить число 3,2 до ноля разрядов:

=ОКРУГЛВВЕРХ(3,2;0), что равно 4

Округлите число вниз с помощью функции ОКРУГЛВНИЗ. Она работает точно так же, как функция ОКРУГЛ, за исключением того, что она всегда округляет число в меньшую сторону. Например, необходимо округлить число 3,14159 до трех разрядов:

=ОКРУГЛВНИЗ(3,14159;3), что равно 3,141

Совет: Чтобы познакомиться с другими примерами и поработать с ними в книге Excel Online, см. статьи Функция ОКРУГЛ,Функция ОКРУГЛВВЕРХ и Функция ОКРУГЛВНИЗ.

Щелкните пустую ячейку.

На вкладке Формулы в разделе Функция нажмите кнопку Построитель формул.

Выполните любое из описанных ниже действий.

В построитель формул найдите и дважды щелкните

В области Аргументы

Округление числа вверх

Введитечисло, округля его. В num_digitsвведите 0, чтобы округить число до ближайшего целого.

Округление числа вниз

Введитечисло, округля его вниз. В num_digitsвведите 0, чтобы округить число до ближайшего целого.

Введитечисло, округля его.

Округка до нечетного числа

Введитечисло, округля его.

Округка числа до ближайшего числа, кратного другому

Щелкните поле рядом с несколькимии введите ближайшее число, кратное.

Нажмите клавишу RETURN.

Стандартный десятичный разделитель для чисел можно настроить в параметрах Excel.

Нажмите кнопку Параметры (Excel 2010 Excel 2016) или кнопку Microsoft Office > Excel Параметры (Excel 2007).

В категории Расширенные параметры нужно выбрать пункт Параметры правки, а затем установить флажок Автоматическая вставка десятичной запятой.

В поле Число знаков после запятой введите положительное число для количества цифр справа от запятой или отрицательное число для количества цифр слева от запятой.

Примечание: Например, если ввести 3 в поле Число знаков после запятой, а затем — 2834 в ячейке, то значение будет равно 2,834. Если ввести –3 в поле Число знаков после запятой, а затем — 283 в ячейке, то значение будет равно 283000.

Нажмите кнопку ОК.

В строке состояния будет отображаться индикатор Фиксированный десятичный формат.

Выберите ячейку на листе и введите нужное число.

Примечание: Установка флажка Фиксированный десятичный формат не влияет на уже введенные данные.

Чтобы не использовать для числа параметр «Фиксированный десятичный формат», при его вводе добавьте десятичную запятую.

Чтобы удалить десятичные запятые из чисел, введенных с использованием фиксированного десятичного формата, сделайте следующее:

Нажмите кнопку Параметры (Excel 2010 Excel 2016) или кнопку Microsoft Office > Excel Параметры (Excel 2007).

В категории Расширенные параметры в разделе Параметры правки снимите флажок Автоматическая вставка десятичной запятой.

В пустой ячейке введите число, соответствующее числу десятичных знаков, которое вы хотите удалить, например 10, 100 или 1000.

Например, введите 100 в ячейке, если числа содержат два десятичных знака и вы хотите преобразовать их в целые числа.

На вкладке Главная в группе Буфер обмена нажмите кнопку Копировать или нажмите CTRL+C.

Выделите на листе ячейки, содержащие числа с десятичными разрядами, которые вы хотите изменить.

На вкладке Главная в группе Буфер обмена щелкните стрелку под кнопкой Вставить и выберите команду Специальная вставка.

В диалоговом окне Специальная вставка в разделе «Операция» выберите Умножить.

Дополнительные сведения

Вы всегда можете задать вопрос специалисту Excel Tech Community или попросить помощи в сообществе Answers community.

Как округлить числа в Excel — разные способы

Первый способ. Выделить одну или несколько ячеек, содержащих цифры, которые следует округлить. На вкладке «Главная» в разделе «Число» выбрать кнопку «Уменьшить разрядность». Нажать нужное количество раз. С каждым нажатием после запятой останется на одну цифру меньше.

Второй способ. Выделить одну или несколько ячеек, содержащих цифры, которые следует округлить. Нажать правую кнопку мыши, выбрать «Формат ячеек». На вкладке «Число» выбрать формат «Числовой», указать необходимое число десятичных знаков (количество знаков после запятой).

Третий способ. Использование функции «ОКРУГЛ». Ставим курсор в ячейку, где желаем получить результат – например, рядом с первоначальным числом. Набираем формулу: =ОКРУГЛ(число; число_разрядов), где число – ссылка на первоначальное число, число_разрядов – число цифр после запятой. При этом если число разрядов поставить отрицательное, цифра будет округляться до определенного разряда. Например, в ячейке А1 стоит число 314. Если запишем формулу =ОКРУГЛ(А1;-1), результат будет 310, если запишем формулу =ОКРУГЛ(А1;-2), результат будет 300.

Четвертый способ. Использование функции «ОКРУГЛТ» округляет число до желаемой точности. Например, при заданной формуле =ОКРУГЛТ(А1;10) наше число 314 округлится до 310, при заданной формуле =ОКРУГЛТ(А1;100) число 314 округлится до 300.

Ссылка на основную публикацию